Как установить LICQ под Linux
Печать: Шрифт: Абв Абв Абв
admin 11 Января 2009 в 20:48:21


Сегодня поставил у себя менеджер мгновенных сообщений LICQ под Linux.

Рассказываю как это делается:

1 Качаем исходники с официального сайта http://www.licq.org/wiki/LicqDownload
В данный момент у меня версия 1.3.6

2 Распаковываем архив
tar -xvjpf licq-1.3.6.tar.bz2

3 Переходим в распакованную папку
cd licq-1.3.6

4 Конфигуряем исходники
./configure --prefix=/usr/local/icq

У меня конфигурация закончилась без ошибок вот такими строками:
Please remember to use GNU make, often installed as gmake.

Install prefix : /usr/local/icq
Licq Includes : /root/licq-1.3.6/include
KDE : includes in /opt/kde3/include, libs in /opt/kde3/lib
Qt includes : /usr/lib/qt3/include
Qt libraries : /usr/lib/qt3/lib, -lqt-mt
Qt moc : /usr/lib/qt3/bin/moc
GPG : disabled.

5 После даём команду
make && make install

6 Теперь нужно установить плагин qt-gui таким же способом
cd plugins/qt-gui
./configure --prefix=/usr/local/icq --with-kde
make && make install

Как запустить?
Все файлы лежат в /usr/local/icq, этот путь мы указали во время установки.
cd /usr/local/icq/bin/
./licq

Всё готово, запускается приложение.

ПС В процессе конфигурирования и компиляции наш друг обязателно будет ругаться на нехватку библиотек. Внимательно читаем чего не хватает и после их установки пытаемся сконфигурять заново.
Комментарии, по рейтингу, по дате
  Гость 12.01.2009 в 12:36:20   # 8006
Спасибо! Примим к сведению.
  Гость 15.02.2010 в 23:39:23   # 34901
Спасибо)
  Гость 08.03.2010 в 10:25:20   # 36906
У меня SUSE 11.1 GNOME пробую , а он мне ошибки при конфигурации configure: error: no acceptable C compiler found in $PATCH
See `config.log for more detalis
  Гость 08.03.2010 в 10:32:11   # 36907
Не понимаю, зачем огород городить? Есть же для гнома прекрасно работающие емпати, пиджин. Наверняка они в сюзевских репах есть.
Край под вайном квип вполне нормально работает.
  Ядерщик 08.03.2010 в 11:24:59   # 36908
Quote:
configure: error: no acceptable C compiler found in $PATCH
See `config.log for more detalis

Компилятор си у тебя не стоит, установи его через яст
  Гость 08.03.2010 в 12:14:22   # 36913
не, ну чем вас пиджин не устраивает? Полная интеграция в гном, куча поддерживаемых форматов, море плагинов.
  Гость 27.03.2010 в 05:29:11   # 38678
  Гость 30.04.2010 в 18:02:36   # 42627
  Гость 05.10.2010 в 21:24:29   # 66361
я нечего не поняла!((((
  Гость 16.10.2010 в 12:17:46   # 68726
./configure --prefix=/usr/local
-bash: ./configure: Нет такого файла или каталога
Что надо сделать?
  Ядерщик 16.10.2010 в 13:05:32   # 68733
в распакованной папке этот файл должен быть обязательно. Может ты не из той дериктории пытаешся запустить
  Гость 16.11.2010 в 15:51:08   # 79015
а с какой надо устанавливать?
  gfksx 16.11.2010 в 17:11:54   # 79114
Не, ну все таки. Ну чем вас дистрибутивные аськи не устраивают? Уже несколько лет пользуюсь пиджином. Ни разу не пожалел.
  Гость 09.12.2010 в 14:38:12   # 88529
у меня не даёт поставить 0 в конце в аське
Добавить сообщение
Чтобы добавлять комментарии зарeгиcтрирyйтeсь